Monthly Archives: November 2010

Debugging Mootools 1.2.4, Rails 3 UJS Problems… Solved!

In Times Of Crisis… Spent a whole evening last night trying to get the Mootools Rails 3 UJS driver working correctly. Links created in templates were recognised as having “data-remote” attributes as rails.js applies events on domready but dynamically created … Continue reading

Posted in Gotchas, Javascript, RoR, Ruby | Tagged , , , , , | 2 Comments

Only Return Items With An Image Link From Google Base API

I was sure there must be a way to do this but for the life of me couldn’t figure it out… Until I found this thread which had exactly what I was looking for. Just add [item+flags:image] to the query! … Continue reading

Posted in Gotchas, Programming | Leave a comment

Ubuntu Multiple Monitors

After a little bit of digging I now have the problem of my laptop showing the correct screen resolution as a secondary monitor alongside my 22″ widescreen. I installed  “Multiple Screens” application from the Ubuntu Software Centre and set the … Continue reading

Posted in Random Stuff | Leave a comment

Setting Primary Monitor in Ubuntu

I’ve just (finally) made the switch and made our house Microsoft free. Both the laptop and desktop machines are both running Ubuntu 10 now. The desktop machine is pretty much unusable for anything other than watching films on so when … Continue reading

Posted in Ubuntu | Leave a comment

Resetting Root Password For PostgreSQL (Ubuntu 10)

Installed PostgreSQL but had trouble logging in as the postgres superuser. Found help here… http://linuxadminzone.com/recover-or-reset-root-password-of-mysql-and-postgresql-servers/ (note… i had to sudo su postgres to get into postgres home directory, then had to switch back to my account user to open pg_hba.conf) … Continue reading

Posted in Gotchas, Ubuntu | Leave a comment

gem install nokogiri fails if libxml2 and libxslt packages aren’t installed

I’ve had to do a couple of setups over the past few weeks and every time I forget about this so here’s a reminder. The Nokogiri gem requires libxml2 and libxslt to install. Otherwise it throws this horrible make error … Continue reading

Posted in Gotchas, Ruby | Tagged , , | Leave a comment

Ronseal Ruby 1.9.2-p0/Rails 3 install instructions for Ubuntu 10.1

Just found these install instructions for Ruby 1.9.2-p0 and Rails 3 which don’t assume you already have a Ruby installation.  The instructions are actually for Ubuntu 10.4 but I’ve had no problems installing on Ubuntu 10.10. I was going to … Continue reading

Posted in Programming, Ruby, Ubuntu | Tagged , , , , | 2 Comments