Monthly Archives: April 2010

SQLServer + Ruby + Updated gems = A Complete Pain In The A***

Needs activerecord_sqlserver_adapter -v 1.0.0 Needs Ruby-DBI -v 2.2.2 Install activerecord_sqlserver_adapter as gem Install Ruby-DBI by downloading zip, unpacking and running setup.rb tasks

Posted in Random Stuff | Leave a comment

Problems building gems on Windows

If you use Ruby on Windows you’re probably quite familiar with this error message Building native extensions. This could take a while… ERROR: Error installing gem-name: ERROR: Failed to build gem native extension. It’s not that it’s impossible to solve … Continue reading

Posted in Ruby | Tagged , , , , , | Leave a comment